Game keeps opening up in 800x600p

azntony360

Sea Legs
No matter what I do in the in game settings, set it to full screen 1600x1200 or windowed 1920x1080, save, then log out/quit game. When I start up the game again through the launcher, it reverts back to 800x600 windowed.

It's a little annoying to have to keep adjusting the resolution everytime I start the game.

I only have 1 monitor, its 3840x2160. Even if its my monitor, I still think that's whack that the game can't just simply open the game in 1920x1080.
 

Bart Gunshot

Site Founder
For windowed mode simply resize/maximize your window, TLOPO's resolution automatically sets itself according to the size of the window. For fullscreen:
1. go to:
C:\Program Files (x86)\TLOPO or C:\Program Files\TLOPO

2. find p_working_options and open it with notepad, or a text editor of your choice

3. find
Code:
fullscreen_width
2560
fullscreen_height
1440

fullscreen 
1
4. change the numbers to what you'd like. And make sure to change fullscreen to 1. (0 is windowed)

5. save and exit

6. [very important] copy and paste this file 2 times. once as game_options once as last_working_options. overwrite existing, edit existing, however you want to do it.

You should now have 3 files game_options, last_working, p_working_options all with the same exact content. The game will now load from these settings. Why are there 3 files? Why cant we just edit game_options and have it work 100%? Why did pyp break this? Why did my wife leave me? What is the meaning of life?? No one really knows. But this is a workaround.
 
Last edited:

squintz

Pirate Lord
1. go to:
C:\Program Files (x86)\TLOPO or C:\Program Files\TLOPO

2. find p_working_options and open it with notepad, or a text editor of your choice

3. find
Code:
window_width
800
window_height
600
fullscreen_width
2560
fullscreen_height
1440
4. change the numbers to what you'd like. window_* controls windowed mode, fullscreen_* controls fullscreen mode

5. save and exit

6. [very important] copy and paste this file 2 times. once as game_options once as last_working_options. overwrite existing, edit existing, however you want to do it.

You should now have 3 files game_options, last_working, p_working_options all with the same exact content. The game will now load from these settings. Why are there 3 files? Why cant we just edit game_options and have it work 100%? Why did pyp break this? Why did my wife leave me? What is the meaning of life?? No one really knows. But this is a workaround.
Ohh, that's recently newish. I only have the single one edited and so far it's holding. Think I'll just leave it for now.

That's a 4K panel AZ has, can Tlpop even do that rez, or will it scale down to 2560X1440 anyways. And @AZ, that setting may or may not show up in the in game settings screen. Mine still displays 800X600 in settings even thought I know I have the higher rez working.

I'm sorry you're wife left you, Bart. But mine may be available?
 
Last edited:

Bart Gunshot

Site Founder
Ohh, that's recently newish. I only have the single one edited and so far it's holding. Think I'll just leave it for now.
There were a few people I’ve seen since my last post that didn’t even have a game_options file. Also even on my end I’ve noticed it fails to load new changes from it occasionally. This newer solution should always work no matter what. But if editing game_options works fine I’d stick to that, obviously a little less work.

Any fix for getting rid of the Fancy Loading Screen ?
Yes, same steps as above, but edit
Code:
fancy_loading_screen
1
1 = True (in this case new loading screen)
0 = False (in this case old loading screen)

Same goes with any of the options listed in the file. Some don't have any effect though.
 
Last edited:

ThunderStorms

Pirate Lord
There were a few people I’ve seen since my last post that didn’t even have a game_options file. Also even on my end I’ve noticed it fails to load new changes from it occasionally. This newer solution should always work no matter what. But if editing game_options works fine I’d stick to that, obviously a little less work.


Yes, same steps as above, but edit
Code:
fancy_loading_screen
1
1 = True (in this case new loading screen)
0 = False (in this case old loading screen)

Same goes with any of the options listed in the file. Some don't have any affect though.
TY ! Bart ! Screen now loads with correct settings ! All 3 options where set to 0 , I reset them will see If that works !
 

ThunderStorms

Pirate Lord
I might be confused ..... The old loading screen showed % correct ? Either way I changed all 3 to " 1 " And have it now with the % showing !! :)
 

squintz

Pirate Lord
There were a few people I’ve seen since my last post that didn’t even have a game_options file. Also even on my end I’ve noticed it fails to load new changes from it occasionally. This newer solution should always work no matter what. But if editing game_options works fine I’d stick to that, obviously a little less work.


Yes, same steps as above, but edit
Code:
fancy_loading_screen
1
1 = True (in this case new loading screen)
0 = False (in this case old loading screen)

Same goes with any of the options listed in the file. Some don't have any effect though.
I think the fancy loading screen is very sporadic for some reason. Sometimes I get the fancy shmancy one, sometimes just the one with the horizontal square thing. Always wondered why the little timer thingie with the red animated spinning strip is counter clockwise. Is that a British thing?
 

squintz

Pirate Lord
I might be confused ..... The old loading screen showed % correct ? Either way I changed all 3 to " 1 " And have it now with the % showing !! :)
Does it seem to load any faster? When I tried to play with that file, I created a space between lines that wasn't there before and nothing was happening. Went back took the space out and it worked. Or it was the other way around? Either way, my edit caused problems with just a space or line difference.
 

azntony360

Sea Legs
1. go to:
C:\Program Files (x86)\TLOPO or C:\Program Files\TLOPO

2. find p_working_options and open it with notepad, or a text editor of your choice

3. find
Code:
window_width
800
window_height
600
fullscreen_width
2560
fullscreen_height
1440
4. change the numbers to what you'd like. window_* controls windowed mode, fullscreen_* controls fullscreen mode

5. save and exit

6. [very important] copy and paste this file 2 times. once as game_options once as last_working_options. overwrite existing, edit existing, however you want to do it.

You should now have 3 files game_options, last_working, p_working_options all with the same exact content. The game will now load from these settings. Why are there 3 files? Why cant we just edit game_options and have it work 100%? Why did pyp break this? Why did my wife leave me? What is the meaning of life?? No one really knows. But this is a workaround.
Sorry I couldn't update my issue here on the forum. I wrote this before I went to bed. I just came home today.

I've already tried this before writing this forum post. Reason I knew to do it was because many of the games I've played had settings files in the game folder, so I decided to check there first. Thought the in game settings were broken or something, but I guess not. I changed the text to the max resolution available that the in game menu offers. ie 1920x1080 & 1600x1200. I've even tried to make all those 3 files as "read only", no luck. Launching the game still brings me to 800x600. And going back to the text files, 2 of them are the same as when I edited, but the "p_working_options" has reverted to 800x600/1600x1200. I've also tried to clear the cache alongside the text changes, nada.

I prefer the 1600x1200 in fullscreen but if it opens up in windowed 1920x1080, I wouldn't mind. 800x600 is tiny and is hard to even navigate to change the res. The window seems to be 1/8th of my screen.

I also understand my monitor is a bit much for the average user, but I believe opening the game in 1080 windowed isn't any different than a 600 window on a 2160 monitor. 1600x1200 is a bit much for upscale issues to 2160 for full screen so I understand that.

My issue is having to navigate the tiny window to change to fullscreen. Really annoying to say the least.
 

Bart Gunshot

Site Founder
I prefer the 1600x1200 in fullscreen but if it opens up in windowed 1920x1080, I wouldn't mind. 800x600 is tiny and is hard to even navigate to change the res. The window seems to be 1/8th of my screen.

I also understand my monitor is a bit much for the average user, but I believe opening the game in 1080 windowed isn't any different than a 600 window on a 2160 monitor. 1600x1200 is a bit much for upscale issues to 2160 for full screen so I understand that.
I have a 2560x1440 monitor and the fullscreen options work fine for me (at any custom resolution I input as well). Testing just now with the windowed options I do see those have no effect currently, I'll update what I said. But if your problem is when using windowed mode, why not just hit the maximize button or drag your window to size? TLOPO dynamically adjusts it's windowed resolution to the size of the window, even though it will still say its 800x600 in the settings.

My issue is having to navigate the tiny window to change to fullscreen. Really annoying to say the least.
There is a fullscreen entry in the option files. Just set it to 1 and the game will launch in fullscreen if that is preferable.
 

azntony360

Sea Legs
I have a 2560x1440 monitor and the fullscreen options work fine for me (at any custom resolution I input as well). Testing just now with the windowed options I do see those have no effect currently, I'll update what I said. But if your problem is when using windowed mode, why not just hit the maximize button or drag your window to size? TLOPO dynamically adjusts it's windowed resolution to the size of the window, even though it will still say its 800x600 in the settings.


There is a fullscreen entry in the option files. Just set it to 1 and the game will launch in fullscreen if that is preferable.
Just looking for an option where it's fully opened, no need to adjust anything. The 1 in full screen seems to have done the trick, no more opening the game in 800x600. Thanks for your help. Changing the text resolution for full screen seemed to not do anything.
 
Top