Blog Post MASSIVE MACOS FIX NOW LIVE!

Discussion in 'TLOPO News and Announcements' started by John Foulroberts, Mar 12, 2018.

  1. John Foulroberts

    Admin

    Joined:
    Oct 25, 2010
    Messages:
    5,126
    Likes Received:
    17,335
    bc8dc5d6cbd434766d7c4f0ba599aa92.jpg_558x314.jpg
    Posted by The Crew on March 11, 2018, 10 p.m.

    Ahoy, everyone!

    Are you a macOS player? Have you been crashing whenever you head out to sea, walk around, or really just anywhere? Well, today’s update is just for YOU! Yes, YOU!

    We’ve heard your cries! In fact, we’ve been receiving thousands of messages about this issue. And today we are finally releasing a patch! All macOS users can now play with sound effects ON!

    For a while now, macOS players have been unable to engage in any kind of gameplay without crashing. This was due to a pesky audio bug. The only way to bypass this was turning off sound effects in-game.

    This also affected pirates when trying to break out of jail. The Navy was sure happy about this bug, so we just HAD to do something! Those jails were getting full, and that’s no life for a pirate!

    This issue has been present in TLOPO since the release of macOS support back in September 2015. Our developers have been studying this issue ever since, and it’s been stumping us for years.

    Rather than bore you with the technical details, we’ll just say that this was an INCREDIBLY difficult bug to fix located inside the core of our engine. It would be wrong to not give a special shoutout to the Panda3D team for releasing an update that fixed this. They are brilliant people and we hope you check them out!

    Now, we’re well aware there are other issues with the macOS client. Double backspace, broken caps lock, and camera panning issues are just a few of the other bugs macOS users have been experiencing. And don’t worry, we have been cooking up some well-deserved fixes those issues and many more! Just hold on a bit longer!

    A little sneak peek: We are working on another big engine update which will help reduce a lot of lag players are experiencing in-game. This won’t be a final solution, but it will most certainly help! So stay tuned for that fix coming very soon!

    Thank you all again for your continued patience and support! See you on the High Seas!

    ~ The Crew @ The Legend of Pirates Online
     
    #1
  2. PrivateRiley

    PrivateRiley Pirate Lord

    Joined:
    Feb 9, 2016
    Messages:
    5,203
    Likes Received:
    1,390
    With sound on, I attempted to board the same ship 4 times. Each time I loaded onto the ship I crashed almost immediately. Once I turned off sound and reboarded the same ship I was able to repair, shoot cannon, etc. without crashing. I tested this again on a few more ships and with different pirates and came to the same conclusion.

    Edit: This occurred on my mac. Sailing with sound works fine on my windows computer.
    Edit 2: A second patch fixed the sound bug. Refer to John Foulrobert's post below.
     
    #2
    Last edited: Mar 13, 2018
  3. Bambino

    Bambino Dockworker

    Joined:
    Mar 12, 2018
    Messages:
    2
    Likes Received:
    1
    Mac user here and issues are still occuring
     
    #3
  4. patbona

    patbona Buccaneer

    Joined:
    Feb 25, 2018
    Messages:
    46
    Likes Received:
    20
    Today at 5 pm GMT a new TPOLO update installed on my Mac. After that update I was able to sail with sound effects enabled. Did that work for you?
     
    #4
  5. Eric Sailcutter

    Eric Sailcutter Pirate Lord

    Joined:
    Jan 1, 2017
    Messages:
    1,126
    Likes Received:
    947
    Is that after installing the update?
     
    #5
  6. patbona

    patbona Buccaneer

    Joined:
    Feb 25, 2018
    Messages:
    46
    Likes Received:
    20
    For me the update installed twice. A 1st time yesterday, and one today at 5pm GMT. Now I don't crash with sound effects enabled.
     
    #6
    Eric Sailcutter likes this.
  7. John Foulroberts

    Admin

    Joined:
    Oct 25, 2010
    Messages:
    5,126
    Likes Received:
    17,335
    There was an issue originally publishing this patch. We've since corrected the issue and redeployed the fix. If you try logging into the game, the launcher should pull the update.
     
    #7
  8. PrivateRiley

    PrivateRiley Pirate Lord

    Joined:
    Feb 9, 2016
    Messages:
    5,203
    Likes Received:
    1,390
    What John said. It seems to work now!
     
    #8
    Eric Sailcutter and patbona like this.
  9. squintz

    squintz Pirate Lord

    Joined:
    May 19, 2017
    Messages:
    1,679
    Likes Received:
    921
    Is the mouse angle flipping glitch corrected this time too. He did say they were very aware of that problem and it makes it nearly impossible to navigate ship or pirate.
     
    #9
  10. PrivateRiley

    PrivateRiley Pirate Lord

    Joined:
    Feb 9, 2016
    Messages:
    5,203
    Likes Received:
    1,390
    I’m pretty sure that isn’t fixed. An update to fix the rest of the bugs on mac probably won’t be out for at least a little while. I believe those fixes will be coming when they release their large engine update.
     
    #10